Logging in via Single Sign-On (SSO) is currently degraded

Incident Report for Rentman

Resolved

This incident has been resolved.
Posted Sep 21, 2026 - 16:55 CEST

Monitoring

A fix has been deployed and SSO enforcement is working as expected again.
If you still experience issues, please log out and log in again.
We are monitoring the situation.
Posted Sep 21, 2026 - 12:57 CEST

Investigating

SSO enforcement is currently not working as expected. Workspaces with SSO enforcement enabled may experience login issues.
Workaround: workspace admins can temporarily disable SSO enforcement. Logging in via SSO itself remains available.
We are working on a fix and will post an update shortly.
Posted Sep 21, 2026 - 12:07 CEST
This incident affected: Rentman Application.