Limited phone support
Incident Report for Rentman
Resolved
The issue has been resolved and we are available again on all phone lines.
Posted May 04, 2021 - 11:51 CEST
Investigating
We are experiencing issues with our phone system, which may result in the support lines for Italy, France and DACH not being available. While we are waiting for the issue to be resolved, please send us an email, open a chat, or contact us at +31 30 711 6844
Posted May 04, 2021 - 10:55 CEST