Outage
Incident Report for Rentman
Resolved
This incident has been resolved.
Posted Jan 25, 2022 - 13:27 CET
Monitoring
All servers are back online and everything should be running as normal.
We are monitoring the issue and investigating the cause of this outage. If we know more we will post an update here.

If you are still experiencing problems, do not hesitate to get in touch:
https://www.rentman.io/contact

We apologize for any inconvenience caused by the downtime.
Posted Jan 25, 2022 - 12:12 CET
Investigating
Rentman is experiencing an issue at the moment. We are currently investigating it and will provide further updates as they are available.
Posted Jan 25, 2022 - 11:45 CET
This incident affected: Rentman Application.