Outage
Incident Report for Rentman
Resolved
This incident has been resolved.
Posted Sep 16, 2021 - 16:51 CEST
Update
We are continuing to investigate this issue.
Posted Sep 16, 2021 - 16:51 CEST
Investigating
Rentman is experiencing an issue at the moment. We are currently investigating it and will provide further updates as they are available.
Posted Sep 16, 2021 - 16:48 CEST
This incident affected: Rentman Application.