Issues with the performance of Calendar Sync
Incident Report for Rentman
Resolved
Infrastructural measures have been taken to improve stability and performance.
Posted Jul 19, 2023 - 15:43 CEST
Investigating
We are currently investigating this issue.
Posted Jul 19, 2023 - 14:30 CEST
This incident affected: Calendar sync.