Email delivery delay
Incident Report for Rentman
Resolved
We have been closely monitoring the delays in sending and have seen great improvement in performance. You should start seeing messages that were previously stuck in accepted state to start being delivered.
Posted May 30, 2018 - 19:21 CEST
Monitoring
Mailgun contacted us about the issue and informed us that a fix has been implemented.
It turned out that only messages with attachments were affected.
We are monitoring the emails to see if they are being delivered as normal. When we have more information we will post an update here.

If you are still experiencing problems, do not hesitate to get in touch:
https://www.rentman.io/contact
Posted May 30, 2018 - 16:40 CEST
Identified
We have received reports of emails taking a long time to deliver.

We have investigated the issue and we identified the problem to be at our provider for transactional email, Mailgun. The emails are being accepted by Mailgun, but the delivery can take a couple of hours to process.

We are in contact with Mailgun to resolve the issue. We will post an update as soon as we have more information.

We apologize for any inconvenience.
Posted May 30, 2018 - 13:23 CEST
This incident affected: Email delivery (Outbound Delivery).